Apache Doris 中文技术论坛
Questions Tags Users Badges

ROUTINE LOAD导入kafka数据,当kafka是cdc数据,JSON格式,带删除标识的:op:d

Asked Apr 15 Modified Jan 1, 0001
Viewed 49
2.1 content ingestion

导入到doris中,只会增加数据,无法识别当op:d时候,需要对数据做删除操作,这个可以实现根据op对数据进行操作吗

edited Jan 1, 0001
ASJW32115
asked Apr 15
1 Answers

routineload 无法实现这个操作,这种只能使用Doris中的 kafka catalog + streaming job + merge into的方式,但是这种方式还没release(CREATE STREAMING JOB)。

或者就是用flink 先做一次处理。

edited Jan 1, 1970
阿渊@SelectDB (没回帖直接加我主页微信)10485
answered Apr 15
Related Questions
Doris2.1.6升级为Doris2.1.11后全部be节点进程频繁停止运行
1 answers
Huawei MRS使用doris,tpc-ds测试运行load data至analyse时报错
1 answers
doris2.1.11版本漏洞
1 answers
with as加insert into报错,解析器解析不到insert into后面的内容
1 answers
FE的JVM每天以1%的频率增长,原因是什么:Doris2.1.6
1 answers
Doris 2.1.6版本升级至4.1.3版本详细升级路径疑问。
1 answers

Terms of service Privacy policy

Powered by Answer - the open-source software that powers Q&A communities.
Made with love © 2026 Apache Doris 中文技术论坛.