Apache Doris 中文技术论坛
Questions Tags Users Badges

[Doris2.1.7]开启SSL后,powerbi直连报错:SSL connection error: protocol version mismatch

Asked Nov 6, 2025 Modified Jan 1, 0001
Viewed 100
2.1

Doris版本2.1.7,Mysql odbc 为 5.3.10,powerbi 通过custom doris连接器 Direct mode连接doris报以下错误
9faede60385c9f23095db45fbf2540e6.png

edited Jan 1, 0001
cloudinamoy1
asked Nov 6, 2025
2 Answers

该报错原因是 Doris 开启了 SSL 验证,但是连接过程中未使用 SSL 连接,需要在 fe.conf 里面关闭 enable_ssl 变量。

edited Jan 1, 1970
徐振超@SelectDB(可以直接加微信Faith_xzc)8286
answered Nov 8, 2025

是希望powerbi 通过SSL连接doris的,请问需要如何配置?

edited Nov 10, 2025
cloudinamoy1
answered Nov 10, 2025
Related Questions
SelectDB Doris 2.1.8-3 升级使用灵活部分列更新,推荐版本及升级流程咨询
1 answers
Flink Connector 26.3.0 读取 DATETIME 变成 1970 年,切换 25.0.0 后正常
1 answers
max_by会不会忽略null值
1 answers
Apache Doris默认口令登录漏洞
Apache Doris Dashboard未授权访问漏洞
1 answers
Doris2.1.6升级为Doris2.1.11后全部be节点进程频繁停止运行
1 answers

Terms of service Privacy policy

Powered by Answer - the open-source software that powers Q&A communities.
Made with love © 2026 Apache Doris 中文技术论坛.