Questions
Tags
Users
Badges
All Questions
Newest
Active
Unanswered
Frequent
More
Score
View
Card
Compact
odos
3
•
asked May 24, 2025
删除语句执行6小时
审计日志: 2025-05-24 05:41:27,239 [query] |Client=10.1.106.158:17916|User=root|Ctl=internal|Db=tsib|State=OK|ErrorCode=0|ErrorMessage=|Time(ms)=21600464|ScanBytes=0|ScanRows=0|ReturnRows=0|StmtId=8388309|QueryId=d9defb8d8f5c4afb-bf38eb1f3b7c4c8...
2.1
0
votes
1
answers
53
views
____
5
•
asked May 23, 2025
2.1.7 Insert into 表 select java UDF 报错 not enough streams
使用JDBC链接,BE节点报错 java.sql.SQLException: errCode = 2, detailMessage = (10.1.1.1)[CANCELLED]failed to open DeltaWriter 2569782237: not enough streams 1/3 请问有经验的老哥 可能是由于什么问题导致的,要如何处理呢?
2.1
0
votes
1
answers
52
views
typer
1
•
asked May 23, 2025
date_trunc函数使用问题
字段rtc_datetime为datetime类型,在<=doris3.0.3是可以按照预期筛选出满足条件数据,但是升级到3.0.5后,就无法按照预期执行了。请问这是什么问题呢? DATE_TRUNC(rtc_datetime, 'DAY') = DATE_TRUNC('2025-05-23 15:30:28', 'DAY'); PS: 以下也是可以按照预期执行的 DATE_TRUNC(concat(rtc_datetim...
3.0
0
votes
2
answers
78
views
xu
1
•
asked May 23, 2025
使用jdbc创建物化视图的时候,报错Encountered: BUILD
mysql-connector-j版本为8.3.0 doris版本为2.1.9 使用jdbc创建物化视图时报错,我怎么能直接创建或者让他不报错 物化视图创建语句 {code...}
mtmv
2.1
0
votes
1
answers
58
views
hacker
1
•
asked May 23, 2025
doris2.1.4版本,关于表批量插入数据时,ClickHouse数据库和doris数据库结果不一致问题。
问题出现情景:数据库替换,公司要用Doris替换原本的ClickHouse数据库。但是发现调度任务执行批量插入数据时,CK和doris数据库执行插入SQL后结果不一致,CK会对数值类型字段插入空值时补0,但是doris不会,这导致了数据不一致,业务产生了影响。 简单举例描述一下SQL的情况:A表和B表左关联查询,A表比B表数据全,关联查询中查询B表的字段会因为左关联的原因查询的数字类型的字段为空的情况。此时,把查询的数据用insert into语句入库,在CK表中,数字类型的...
2.1
0
votes
1
answers
34
views
kexue.wang
26
•
asked May 23, 2025
FundationDB 问题 导致 FE 服务无法运行 及后续运维操作问题
描述 起因: FDB Pod 报错 导致服务不正常运行。 {code...} 删除重启后, 对应的 进程id会变, 导致磁盘无法再次找到准确的pod。 进而影响后续的 FE和MS的启动检查 问题03 - 后续服务也启动不起来了 FDB 挂了, 重启后磁盘挂不上,元数据丢失的状况 MS 报错 RuntimeLogger W20250523 07:39:03.721222 176 resource_manager.cpp:220] failed to check instance...
decoupled
3.0
0
votes
1
answers
193
views
yumu
1
•
asked May 23, 2025
doris 中be节点交替false是什么原因呢
doris版本:2.0.4 集群:4个节点,3fe+4be,其中3个fe和be是混部的 问题描述 在做streamload时(3副本),1个副本写入成功,1个副本写入失败(日志显示该be的状态backendAlive=false),1个副本写入成功但丢失了之前的版本 已排查的工作 1、首先检查了各个be节点的状态,都未重启过 2、随后搜索了其他be节点在问题发生时间附近的日志,发现有大量的该错误,有3个be节点轮流是false的状态 3、日志报错信息还有(但是我觉得该问题的原...
2.0
0
votes
1
answers
30
views
inkb
1
•
asked May 23, 2025
我在使用drop force删除分区后,data目录占用空间无变化,过一会才会减少对应分区大小是什么原因呢
我还是不太明白drop分区时加上force后到底进不进回收站,回收站指的是fe的catalog recycle bin还是指be的trash呢?烦请各位解答一下
2.1
0
votes
1
answers
37
views
holmeszhang
1
•
asked May 23, 2025
Doris BE不定期挂掉,目前只有be.out的栈信息,
版本:1.2.4 现象:不定期BE节点进程挂掉,有自动拉起,目前不清楚问题根因 以下是出现过问题的几个BE的be.out截图
memory
cluster
1.2
0
votes
1
answers
51
views
水月洞天
3
•
asked May 23, 2025
大表系统的列统计sql特别耗时
有一张天分区表,存储了较多的数据,随着数据越来越大,发现列统计的sql扫描的数据、内存消耗、cpu消耗、查询消耗都特别大,频次还比较高,基本上一分钟一次,消耗资源特别大,影响到集群的使用。这个表使用flinkcdc实时更新,可能会有新数据不断写入,不存在数据更新,主键表。 doris版本:2.1.5
2.1
0
votes
1
answers
48
views
Prev
Prev
145
146
147
(current)
148
149
Next
Next
Hot Questions
通过spark connector写入数据时,doris.fenodes配置了多个节点,但只有第一个节点生效。
1 answers
Doris3.1.4并发查询速度变慢
1 answers
Doris4.1.2集群BE节点频繁宕机
1 answers
【实测】Apache Doris 4.1.3 元数据接口的 7 个发现(第 0 条是我们自己的 bug)
ranger新增的表权限,在doris中不生效,doris版本 Version : doris-4.1.3-rc02
6 answers
Doris 升级到最新版 4.14 后,Doris Manager 执行SQL报错
3 answers