Questions
Tags
Users
Badges
All Questions
Newest
Active
Unanswered
Frequent
More
Score
View
Card
Compact
Gin
1
•
asked May 12, 2025
使用客户端时,联邦查询如何做SQL自动补全
请问下用客户端(比如dbeaver等)编辑SQL时,如何在联邦查询时能利用多个catalog下的schema进行自动补全? 目前尝试了 doris连接时不指定catalog和database,这时客户端打开的是internal库表,不显示其他catalog,且SQL补全也仅限于internal的库表字段名 doris连接时指定catalog(比如iceberg),这时客户端只显示该catalog库表,SQL补全仅限于该catalog下的各个库表,join内部表无自动补全 使用...
catalog
0
votes
2
answers
71
views
于七
3
•
asked May 12, 2025
doris1.2.7由于查询引发大量be节点服务宕机
F0509 03:19:17.362684 137582 column_string.h:66] string column length is too large: total_length=18446744073709541005 ,element_number=100 除了这个报错还显示了查询id。由此查到了具体的查询sql。 排查了相应的表结构后,发现有较长字段,但没有超出对应字段上限。 经过排查,,此sql一执行就会导致一多半be节点宕机,,且每次宕机的be节点不一...
cluster
1.2
0
votes
1
answers
64
views
1
•
asked May 12, 2025
多表写入问题(1000+张表)
如题,我们想要写入我们的应用埋点日志数据,其中有一部分字段是公共的(例如data_center,ip等),有一部分则完全是用户自定义的(每个应用的字段都不同)。一开始想了两种方案: 1.多表Routine load:一开始设想的是使用routine load一流多表,但一流多表由于表数量多,数据量大,cpu使用率很高,且写入效率低。 2.Variant字段:然后想采用varient的字段来存每个应用独特的字段,把所有应用的日志写入一张表中。但是variant字段总数有限制,1...
3.0
0
votes
1
answers
77
views
like
7
•
asked May 12, 2025
doris2.1.7,有一个insert into seclect 的定时任务每小时跑一次,不定什么时候就报错类型不匹配的问题(一天大概一两次)
报错:invalid column(#4) type: doris::vectorized::ColumnVector, expect type: ColumnString, is nereids: false at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException(SQLError.java:129) 但是第四列的park_id来源和目标表都是bigint类型的 {code...}
2.1
0
votes
2
answers
89
views
benpao
1
•
asked May 11, 2025
高并发点查TPS只有258,求助大佬!
Doris V3.0.4 三千列五百万行数据的宽表根据id查询,主键模型,开启了行存、开启了light_schema_change、开启了行缓存,使用了PreparedStatement,然而压测结果没有什么提升,TPS只有258,求大佬帮忙分析下
3.0
performance
0
votes
1
answers
74
views
zhengby
3
•
asked May 11, 2025
最近生产环境的Be节点总是全部宕机
昨天晚上be节点全部宕机,我查看be.out没有任何堆栈信息,使用dmesg -T命令也看了,没有oom的信息,请教一下,还可以怎么排查一下宕机的原因? doris的版本是2.0.3
cluster
2.0
0
votes
2
answers
61
views
鲁汀
25
•
asked May 10, 2025
[2.1.9] 域名形式的 admin 用户无法删除
{code...} 执行 drop 时报错 ERROR 5064 (42000): errCode = 2, detailMessage = Can not drop system user 在 2.1.6 版本中可以, 2.1.9 版本中不行, root 用户权限也无法删除 这样 admin 给某一个域赋予权限不是永远无法撤销? 出于什么目的修改?
2.1
0
votes
1
answers
44
views
vvtf
3
•
asked May 10, 2025
doris2.1.9, fe和be的这些错误日志有影响没?
首先是be: 在warning中出现大量的: {code...} 1. 请问这些日志有什么影响,是什么原因造成的. 2. 昨天doris挂了一次,不知道什么原因,领导说是查询把doris搞蹦了,但是doris没有自动恢复,需要手动接入,不清楚为什么doris不会自动恢复
2.1
0
votes
1
answers
91
views
____
27
•
asked May 10, 2025
doris集群部署重启报错
doris 的镜像是只能docker 单节点和k8s集群部署吗? doris版本:2.1.8.1、2.1.9 我使用docker 部署1节点 的1fe 1be,首次启动成功,重启也成功 我使用docker 部署3节点 的3fe 3be,首次启动成功,每个节点重启,重启也成功 我使用docker 部署3节点 的3fe 3be,首次启动成功,所有节点关机,再启动,就起不来了,必现 {code...}
2.1
cluster
install
0
votes
1
answers
129
views
____
27
•
asked May 10, 2025
发送奔溃直接退出
版本 2.1.9 {code...}
2.1
faq
1
votes
2
answers
79
views
Prev
Prev
151
152
153
(current)
154
155
Next
Next
Hot Questions
通过spark connector写入数据时,doris.fenodes配置了多个节点,但只有第一个节点生效。
1 answers
Doris3.1.4并发查询速度变慢
1 answers
Doris4.1.2集群BE节点频繁宕机
1 answers
【实测】Apache Doris 4.1.3 元数据接口的 7 个发现(第 0 条是我们自己的 bug)
ranger新增的表权限,在doris中不生效,doris版本 Version : doris-4.1.3-rc02
6 answers
doris 4.0.5 版本,使用 information_schema 查询元信息信息,查询的元信息与实际不符
1 answers