Apache Doris 中文技术论坛
Questions Tags Users Badges

int类型写入数据超过范围不报错

Asked Oct 16, 2025 Modified Jan 1, 0001
Viewed 51
2.1 ingestion

在 严格模式 下,如果列是int类型,但是写入的数据范围超过int
用stream load 写入值会变成 null; insert-sql,则会变成溢出值
有办法直接报错嘛?
c585bb40-3429-4621-8e44-fb65bff51181.jpeg

edited Jan 1, 0001
蜂蜜烤鸡翅17
asked Oct 16, 2025
1 Answers

目前行为:stream load会报错,insert会截断,目前是符合预期的,可以调整表字段类型为 string

edited Oct 27, 2025
阿渊@SelectDB (没回帖直接加我主页微信)10495
answered Oct 27, 2025
Related Questions
Flink Connector 26.3.0 读取 DATETIME 变成 1970 年,切换 25.0.0 后正常
1 answers
SelectDB Doris 2.1.8-3 升级使用灵活部分列更新,推荐版本及升级流程咨询
1 answers
max_by会不会忽略null值
1 answers
Apache Doris默认口令登录漏洞
Apache Doris Dashboard未授权访问漏洞
1 answers
Doris2.1.6升级为Doris2.1.11后全部be节点进程频繁停止运行
1 answers

Terms of service Privacy policy

Powered by Answer - the open-source software that powers Q&A communities.
Made with love © 2026 Apache Doris 中文技术论坛.