Questions
Tags
Users
Badges
All Questions
Newest
Active
Unanswered
Frequent
More
Score
View
Card
Compact
doris
2
•
asked Mar 25, 2025
关于列转行中generator函数的构建
背景:我现在有一个需求就是需要进行列转行(宽表转高表)原格式是 id 一月份金额 二月份金额 001 10000 20000 想转换为 id 月份 金额 001 一月份 10000 001 二月份 20000 我看了社区这个帖子: [【最佳实践】Doris 中实现行列转换,但是这里面的列转行似乎有些构建问题:我看这个demo的列转行,即宽表转高表,为啥一开始说:“首先我借助 Lateral view 形成一个 UserID、客户成绩组成一个字符(使用逗号连接),达到下面的效果...
2.1
0
votes
1
answers
65
views
baijun
15
•
asked Mar 25, 2025
2.1.7 Ranger 策略无效
Doris 2.1.7版本,Ranger 2.5版本,配置了策略但是不生效。 1.Ranger配置了如下策略: user1可以访问tpch1000的表; 2.已经按照要求,将各种配置文件加入fe/conf: 3.ranger cache目录,可以看到ranger的信息已经同步过来,上面第一步的策略已经下发: 4.删除ranger doris插件的所有自动生成的策略(主要是admin用户的各种权限),看日志策略已经刷新: 5.使用user1登陆doris,无法查看tpch100...
2.1
0
votes
1
answers
115
views
49
•
asked Mar 25, 2025
3.0.3 k8s部署 存算分离 ,增加be pod数后,再执行滚动部署,物理机磁盘io持续很长时间 100%
存算分离,be用localpv本地cache数据,设置了500g, be pod数从6个增加到9个后(一台物理机上一个be pod),执行下面的命令 {code...} 9个be会依次重启,pod所在的物理机io 100% 都持续很长时间。 存算分离的模式,cache也会reblance吗?
decoupled
3.0
0
votes
1
answers
90
views
luodesong
5
•
asked Mar 24, 2025
3.0.4,用户资源组隔离部分未生效
已经指定一个用户的默认组为 cg1 但是为什么这个用户 还是会将数据提交到其他的计算组上去; 版本是3.0.4 case: 我的flink_write用户默认的是cg1的组 但是实际flink的写入stream_load的时候还能提交到其他组上去
resource-admin
decoupled
3.0
0
votes
2
answers
123
views
Xiaofan Li
21
•
asked Mar 24, 2025
SELECT ARRAY类型的值时,未转义特殊字符,导致取到的值是无效的JSON字符串
{code...} c1由于未转义\n,导致该字符串为无效JSON,无法进行后续处理。
2.1
2
votes
3
answers
140
views
椰子Echo@SelectDB
1111
•
asked Mar 24, 2025
【资料&新产品下载】终身免费的 Doris 原生数据管理工具!3/27 SelectDB Studio for Apache Doris 功能解读|Webinar(三)
SelectDB Studio 是一款专为 Apache Doris 类数据仓库设计和开发的数据开发与管理工具。它为用户提供可视化的 SQL 查询分析、日志检索分析、查询审计、会话管理、数据管理和权限管理等能力,显著提升数据开发与管理效率。 3 月 27 日 19:30-20:30,飞轮科技 SelectDB Cloud 产品经理李天武将在 SelectDB 视频号、Bilibili 双平台,深度解读 SelectDB Studio 核心价值。 李天武将从业界常见的数据库客户...
community
selectdb-studio
company
1
votes
1
answers
597
views
Doris9
9
•
asked Mar 24, 2025
Doris 2.1.5 be io util 高
doris be 进程 读写数据量不大,但是ioutil极高 通过抓be io情况发现在30s有1000+ memtableflush 通过iotop命令发现jbd2非常高 写入的数据量并不大,但是ioutil极高,大致一些简单的stream load,insert into select 执行非常缓慢,请问该如何排查及优化,谢谢!
2.1
0
votes
1
answers
83
views
Faaaaat_husky
3
•
asked Mar 24, 2025
查询hive表报错,Invalid method name: 'get_table_req'
求教,hive版本是2.1.1,创建了hive的Catalog,show tables没问题,但是在查询表的时候报错,请问这个问题如何解决?
1.2
0
votes
1
answers
139
views
wuzg2000
3
•
asked Mar 24, 2025
doris 2.1.8 创建jdbc catalog报错
doris版本: 2.1.8 fe和be都已配置参数: jdbc_drivers_dir=${DORIS_HOME}/../jdbc_drivers/ 已确认fe、be上jdbc驱动jar包是存在的,且权限没有问题。 创建jdbc catalog报错如下: 2025-03-24 10:27:47,377 WARN (mysql-nio-pool-12040|577293) [StmtExecutor.handleDdlStmt():2879] DDL statement(cr...
catalog
0
votes
2
answers
107
views
hlim2251
1
•
asked Mar 24, 2025
怀疑FE不会释放内存,导致内存一直累积使用,直到FE崩掉
这两张图片,第一张是内存使用过量,导致FE崩掉,manager自动启动了; 第二张是最近7天的FE内存使用情况,按说任务每天执行,内存使用曲线应该是也是按天起伏的,但看起来并不是,所以怀疑是FE不会释放内存,导致内存一直累积使用,直到FE崩掉。 各位大佬看看是不是这个原因。 下面是集群的情况: 1个FE节点,16G内存 1个BE节点,48G内存。 一共300张表,30G数据量。每天用DataX抽数的数据量在20多G左右。
memory
resource-admin
2.1
cluster
0
votes
3
answers
223
views
Prev
Prev
173
174
175
(current)
176
177
Next
Next
Hot Questions
通过spark connector写入数据时,doris.fenodes配置了多个节点,但只有第一个节点生效。
1 answers
Doris3.1.4并发查询速度变慢
1 answers
Doris4.1.2集群BE节点频繁宕机
1 answers
【实测】Apache Doris 4.1.3 元数据接口的 7 个发现(第 0 条是我们自己的 bug)
ranger新增的表权限,在doris中不生效,doris版本 Version : doris-4.1.3-rc02
6 answers
doris 4.0.5 版本,使用 information_schema 查询元信息信息,查询的元信息与实际不符
1 answers