Questions
Tags
Users
Badges
All Questions
Newest
Active
Unanswered
Frequent
More
Score
View
Card
Compact
shuaili
1
•
asked Sep 3
ivf索引一直构建失败
场景:30亿条数据,15T数据量,768维度,96cpu,300G内存,hdd磁盘,3fe,3be,fe和be在一个节点上,共3台节点。构建过程中,经常be宕机,修改sql 内存限制参数后重启be,索引build又卡主,后又cancel了构建任务,之后又重新构建索引,还是一直卡在0的进度,看日志,除了WARN (schema change|33) [ThreadPoolManager$LogDiscardPolicy.rejectedExecution():364] Task...
performance
upgrade
0
votes
2
answers
61
views
17602694497
1
•
asked Sep 1
Doris4.0.5版本有没有可以用低权执行select语句的curl接口
目前我创建了一个只查的账户,但是用/api/query/{db}查询提示405,但是用/api/query/internal/{db},提示低权用户需要有admin的权限,就很难搞,目前生产上有个执行shell的脚本只能用低权用户连接查询,求助🆘
query
0
votes
1
answers
28
views
teng945183777
3
•
asked Aug 31
服务于智能体的Doris湖仓架构该怎么画
这是我画的一个湖仓架构,我刚入公司没多久,公司着急让我出成果,所以我在湖仓一体化平台这里新建了一个数仓准备区,用以清洗数据,后面让智能体开发直接调用。后面再用左边数据仓库就专门给业务数据分层做数仓使用。右边处理的是非结构化数据,因为现在不清楚湖仓一体化该如何设计。所以就想通过MINIIO+MinerU解析,然后存到左边数仓向量数据库,或者存到Milvus里面。事实上之所以在湖仓一体化平台那里画了那么多的双向箭头,是因为智能体那边要求,数据仓库要和数据湖数据融合,之后根据项目还...
decoupled
3.0
catalog
x2doris
operator
0
votes
1
answers
121
views
boston
1
•
asked Aug 30
selectdb 查询审计 无法查看profile
cluster
performance
0
votes
2
answers
40
views
walte
3
•
asked Aug 29
FE的JVM每天以1%的频率增长,原因是什么:Doris2.1.6
2.1
0
votes
1
answers
51
views
wangcool
13
•
asked Aug 27
doris 3.1.4 fe是否内存泄露问题(glm分析)
Doris FE OOM Heap Dump 分析报告 一、宕机概况 项目 详情 FE版本 Doris 3.1.4 JVM配置 -Xmx32768m -Xms32768m(32GB堆) Java版本 OpenJDK 17.0.12 宕机时间 2026-08-17 ~10:54 FE启动时间 2026-08-03 16:05(运行约14天) 宕机原因 java.lang.OutOfMemoryError: Java heap space Heap Dump 30.46GB,54...
memory
0
votes
1
answers
124
views
wangcool
13
•
asked Aug 27
Doris 3.1.4 fe节点内存泄露(kimi分析)
Doris FE OOM Heap Dump 分析报告 项目 内容 集群节点 FE 172.4.8.10(MASTER) Doris 版本 doris-3.1.4-rc02 JDK 17.0.12(崩溃时)/ 17.0.17(现网) 事故时间 2026-08-17 10:55:29 (+08:00) OOM,进程被 OnOutOfMemoryError=kill -9 杀死 堆配置 崩溃时 -Xmx32768m,重启后调整为 -Xmx49152m Dump 文件 /data0...
memory
0
votes
1
answers
110
views
wangcool
13
•
asked Aug 27
Doris 3.1.4 meta_delay_toleration_second 参数设置
在doris3.1.4的默认配置文件中,meta_delay_toleration_second =10,但是官网默认参数时300S。目前生产参数设置10S后,fe editlog 经常延时>10s,造成无法提供服务。请问下meta_delay_toleration_second 建议设置为多大?
install
0
votes
1
answers
56
views
Da Wan
27
•
asked Aug 27
variant类型的a字段本来存放的是json,update b字段时,a字段变成了错误的json字符串,转json失败
Version 4.0.7,遇到问题的场景如下: 现有个表结构如下: {code...} 问了AI给的结论是:Doris 的 UPDATE 不是原地更新,而是整行重写(读旧行 → 计算新行 → 删旧行 → 插新行),问题就出在读回再写回这个环节:variant 列原本存的是 JSON 数组(variant array),在整行重写时它的值被序列化成了 JSON 文本字符串 "[{...}]",写回时 variant 列把这段文本当成**字符串值(variant...
partial-update
0
votes
1
answers
59
views
gy
1
•
asked Aug 25
flink cdc 和 doris 自带的cdc写入都很慢
大佬,帮忙分析一下,4.1.3版本单节点be和fe合并部署 写入耗时和cpu使用率,cpu只使用了单核100,其他核没用,写入耗时8000条要40多秒: 火焰图:
4.1
0
votes
1
answers
84
views
Prev
Prev
2
3
4
(current)
5
6
Next
Next
Hot Questions
Doris4.1.2集群BE节点频繁宕机
ranger新增的表权限,在doris中不生效,doris版本 Version : doris-4.1.3-rc02
doris 4.0.5 版本,使用 information_schema 查询元信息信息,查询的元信息与实际不符
【实测】Apache Doris 4.1.3 元数据接口的 7 个发现(第 0 条是我们自己的 bug)
SelectDB Doris 2.1.8-3 升级使用灵活部分列更新,推荐版本及升级流程咨询
Doris 升级到最新版 4.14 后,Doris Manager 执行SQL报错