Questions
Tags
Users
Badges
All Questions
Newest
Active
Unanswered
Frequent
More
Score
View
Card
Compact
taojun
1
•
asked Jan 22
doris 2.1.11版本 be 不时的飙高到100%,导致查询变慢,有时fe还连接不上
检查到fe飙高的时间段,大量打印如下两类日志: 1.(查询变慢) I20260121 10:26:29.554636 2362623 beta_rowset.cpp:223] deleting /data4/doris_be/be_storage/data/2/10037/1988860573/020000000002ddc4b84ec961d2480aa06f3f5fed3bb219a1_0.dat 2.(fe 连接不上) I20260120 20:00:32.033942...
2.1
0
votes
1
answers
94
views
shuguang
1
•
asked Jan 22
doris的kettle插件写入资源库后无法读取
新建步骤如果保存为ktr文件,再次读取无问题,如果直接存入mysql资源库,再读取出来,会报错 {code...} kettle数据库存储的信息如下:
faq
0
votes
0
answers
48
views
Kevin.Shin
19
•
asked Jan 21
Doris 2.1 SQL 解析错误
Doris 2.1.10 以下SQL是BI软件生成的,执行时遇到错误: [Code: 1054, SQL State: 42S22] errCode = 2, detailMessage = Unknown column 'code' in 'sg_bg_db' 其中的sg_bg_db是数据库名 注释掉SQL最后面任意一个and 条件,都能执行过去。 {code...}
2.1
0
votes
1
answers
65
views
5
•
asked Jan 21
spark往doris写入数据时删除某些数据该如何配置
doris-2.1.10 scala-2.12 在之前我已经执行spark应用写入了一些数据在doris中,现在我根据操作通过withColumn给其中一些数据加上了删除标记: df.withColumn("should_delete",when(col("op") === "d", lit(1).otherwise(0))).drop("op") 当op为d时,表示这条数据之前已经写入了,现在要删除 然后按照查...
2.1
0
votes
1
answers
72
views
只爱吃糖不说话
3
•
asked Jan 21
doris 2.1.11 查询结果错误
创建一个100w的表,使用 row_number + limit 查询的时候,结果集会重复 问题复现: CREATE TABLE test as WITH t as ( SELECT 0 as id UNION ALL SELECT 1 as id UNION ALL SELECT 2 as id UNION ALL SELECT 3 as id UNION ALL SELECT 4 as id UNION ALL SELECT 5 as id UNION ALL SELEC...
2.1
0
votes
1
answers
80
views
chyx018
7
•
asked Jan 21
特定情况下锁表问题
doris2.1.6版本,开启kafka一流多表功能,在高并发查询情况下会有锁冲突,磁盘的读写归零。关闭一流多表,回退到一流一表的情况下恢复正常.这是由于什么问题导致的?后续哪个版本修复了这个问题?
2.1
ingestion
0
votes
1
answers
59
views
BingzZ
11
•
asked Jan 20
集群某个用户的99th Latency过高,但是没找到该用户的查询
查看监控发现有个用户的99th Latency过高, 但是通过 SHOW PROCESSLIST; SELECT * FROM information_schema.active_queries; 查看没有发现存在这个用户的任何查询,这是为什么呢? Doris版本2.1.7
2.1
cluster
0
votes
1
answers
47
views
XQG
17
•
asked Jan 20
Doris 当做ETL使用, 大批量数据提示内存不足
Doris 版本 Doris: 2.1.11 Doris 集群规模 Doris FE: 3个(16c 64g) Doris BE: 总共6个, 分别为 3个(16c 64g) 3个(32c 96g) BE conf: 配置过 mem_limit = 80% 默认: 90% 报错日志1 {code...} 使用场景 场景: source_tbl1 表里面的分区限制后, 有将近1亿数据量, 需要写入目标表, 报错信息如上, 这种是属于标准的内存不足吗?
2.1
0
votes
1
answers
116
views
wangwenbo
11
•
asked Jan 20
创建异步物化视图视图后发现无法命中
版本信息:Doris v2.1.6 创建物化视图 CREATE MATERIALIZED VIEW mv_wwb_test5 BUILD IMMEDIATE REFRESH AUTO ON SCHEDULE EVERY 10 hour DISTRIBUTED BY RANDOM BUCKETS 3 PROPERTIES ('replication_num' = '1') as select F5.dt AS dt, F5.ALL_ AS ALL...
mtmv
0
votes
2
answers
80
views
erdong
11
•
asked Jan 19
streamload 列转换
streamload导入json数据到doris时(json key和表列名完全一致),想对某列做一些简单的转换,例如col3=lower(col3), 此时columns配置需要指定所有字段吗? 全部列指定:columns:col1,col2,col3=lower(col3) 部分列指定:columns:col3=lower(col3) 部分列指定的方式是否可行,col1,col2的值会不会丢
2.1
ingestion
0
votes
1
answers
43
views
Prev
Prev
45
46
47
(current)
48
49
Next
Next
Hot Questions
Doris3.1.4并发查询速度变慢
1 answers
Doris4.1.2集群BE节点频繁宕机
1 answers
【实测】Apache Doris 4.1.3 元数据接口的 7 个发现(第 0 条是我们自己的 bug)
ranger新增的表权限,在doris中不生效,doris版本 Version : doris-4.1.3-rc02
4 answers
doris 4.0.5 版本,使用 information_schema 查询元信息信息,查询的元信息与实际不符
1 answers
Doris 升级到最新版 4.14 后,Doris Manager 执行SQL报错
3 answers